Linux and SDRplay issue

  • This topic has 4 replies, 2 voices, and was last updated by .
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #675
    martinpd
    Participant

      With the instructions in the SDRplay webpage for non-windows workflow for either installing CubicSDR or Uno-xtio as soon as it gets to “cmake..” LinuxMint stops and needs additional info like a path or something. Apparently the two dots represent something I’m supposed to include? I’m not a Linux expert at all so can someone explain what to do at this point.

      #677
      Lee
      Participant

        you’d really need to post the full error to see what’s happening.

        the 2 dots tell the command to use the parent folder, if you cd .. in your home folder you’ll end up in /home

        an alternate work flow source is https://github.com/cjcliffe/CubicSDR/wiki/Build-Linux

        #678
        martinpd
        Participant

          I’m at the installing SoapySDRb in the non-windows instructions, here is what I get this time but still not sure what to do next.

          paul@TOSHIBA-NB205:~$ cd ~/Dev
          paul@TOSHIBA-NB205:~/Dev$ sudo rm -rf SoapySDRPlay
          [sudo] password for paul:
          paul@TOSHIBA-NB205:~/Dev$ git clone https://github.com/pothosware/SoapySDRPlay.git
          Cloning into ‘SoapySDRPlay’…
          remote: Enumerating objects: 17, done.
          remote: Counting objects: 100% (17/17), done.
          remote: Compressing objects: 100% (13/13), done.
          remote: Total 439 (delta 8), reused 10 (delta 4), pack-reused 422
          Receiving objects: 100% (439/439), 138.14 KiB | 1.71 MiB/s, done.
          Resolving deltas: 100% (290/290), done.
          paul@TOSHIBA-NB205:~/Dev$ cd SoapySDRPlay
          paul@TOSHIBA-NB205:~/Dev/SoapySDRPlay$ mkdir build
          paul@TOSHIBA-NB205:~/Dev/SoapySDRPlay$ cd build
          paul@TOSHIBA-NB205:~/Dev/SoapySDRPlay/build$ cmake ..
          — The CXX compiler identification is GNU 7.4.0
          — Check for working CXX compiler: /usr/bin/c++
          — Check for working CXX compiler: /usr/bin/c++ — works
          — Detecting CXX compiler ABI info
          — Detecting CXX compiler ABI info – done
          — Detecting CXX compile features
          — Detecting CXX compile features – done
          CMake Error at CMakeLists.txt:7 (find_package):
          Could not find a package configuration file provided by “SoapySDR”
          (requested version 0.4.0) with any of the following names:

          SoapySDRConfig.cmake
          soapysdr-config.cmake

          Add the installation prefix of “SoapySDR” to CMAKE_PREFIX_PATH or set
          “SoapySDR_DIR” to a directory containing one of the above files. If
          “SoapySDR” provides a separate development package or SDK, be sure it has
          been installed.

          — Configuring incomplete, errors occurred!
          See also “/home/paul/Dev/SoapySDRPlay/build/CMakeFiles/CMakeOutput.log”.
          paul@TOSHIBA-NB205:~/Dev/SoapySDRPlay/build$

          #679
          Lee
          Participant

            seems it cant find SoapySDR, did you compile and install it?

            SoapySDR needs to be done first before SoapySDRPlay.

            • This reply was modified 4 years, 4 months ago by .
            #700
            martinpd
            Participant

              Yes, all of that. I’ve fought Linux for two whole days trying to get this to work. About the time I was coming to the conclusion life was too short for Linux I happened on this page: http://kb9rlw.blogspot.com/2017/06/step-by-step-install-of-sdrplay-rsp2.html and ran his scripts and IT WORKED! (sort of). This was kind of an experiment to see if I could use my old netbook for portable use with my RSP1a. It’s a Toshiba NB205 and W10 slowed it down with constant updates so I installed Mint Cinnamon then MXlinux19.1. With Linux it really flew so I thought since people were running CubicSDR on pi devices it would surely work well on this. I previously tried to get SDRuno to run under Wine but could never get it to link through Soapy as others had done. Unfortunately even at the smallest bandwidth it doesn’t have the beans to keep up and constantly stutters. I give up. With my main home computer being set up to dual boot windows and Linux I’ll continue to use ‘uno with windows and maybe tackle the Wine issue later when I’m not burned out.

            Viewing 5 posts - 1 through 5 (of 5 total)
            • You must be logged in to reply to this topic.