Gqrx not communicating with SoapySDRplay?

SDRPlay Independent Community Forum Forums General Gqrx not communicating with SoapySDRplay?

Tagged: , ,

  • This topic has 5 replies, 2 voices, and was last updated by .
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1045
    martinpd
    Participant

    Linux Mint 19.3
    API 2.13
    SOAPYSDRplay 0.7
    Gqrx 2.11.5
    Gqrx initialization string. Soapy=0, driver=SDRplay

    Using SoapySDRUtil and probe proves that Soapy and the API are communicating with my RSP1a plus the fact that CubicSDR is working fine. My problem is getting Gqrx to work. It just seems like there is no connection between them. I’ve tried installing different versions of soapy and Gqrx in different combinations and tried compiling from source and also package repositories to no avail. What am I missing or not doing? I don’t have much hair left to pull out.

    Paul

    #1050
    Lee
    Participant

    have you tried just sdrplay=0 as the initialization string?
    gqrx is just pretty flaky software.

    #1055
    martinpd
    Participant

    Yes, no joy.

    #1057
    Lee
    Participant

    have you tried the appimage?
    https://github.com/csete/gqrx/releases

    also worth noting gr-osmosdr needs to be compiled with the nonfree option as the sdrplay drivers aren’t opensource.

    #1058
    Lee
    Participant

    just booted back in to linux, the appimage might be no good, try the gqrx-sdr-2.11.5-linux-x64.tar.xz from that page instead that’s the one i have been using. sdrplay=0 works with that.

    #1059
    martinpd
    Participant

    Tried both of those. It’s definitely not happy with just SDRplay=0.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.