SoapySDRPlay API on 64-bit Raspberry Pi OS

SDRPlay Independent Community Forum Forums SDR Software (RSP Compatible) SoapySDRPlay API on 64-bit Raspberry Pi OS

Tagged: 

  • This topic has 2 replies, 1 voice, and was last updated by .
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2008
    StandingWave
    Participant

    Has anyone been able to get the SoapySDRPlay API running on the 64-bit version of Raspberry Pi OS?

    I initially downloaded the package available when one selects Raspberry Pi Os from the download page, which is ‘API 3.07 (for 32bit OS)’. This gave me:

    Architecture: aarch64
    API Version: 3.07
    The architecture on this device (aarch64) is not supported in this installer.
    Please contact software@sdrplay.com for details on platform support.

    I contacted support and opened a ticked and got an e-mail advising me to try select ‘ARM Other’ instead. Here there is a package for ‘API 3.07 (for 64bit OS)’. I downlaoded and tried this one as well, but get the same message.

    I then tried downloading the build scripts and got:

    Sorry only one download of a particular file is permitted per session
    If you really need this file again, please restart your browser.

    I restarted my browser ad instructed but to no avail. The message was still there. I then opened up the site in another browser and was able to download the scripts. Having had a look at the 1installAPI.sh file though, it seems this also just downloads the 32-bit run file. SDRplay do not appear to provide the sources so I guess for now i am stuck.

    I did write an e-mail back to SDRPlay informing them that the 64-bit installer gave me the same error, but so far have heard nothing back. Perhaps they are still looking into it. The 64-bit OS was released only in January 2022 AFAIKT so it is still rather new and we may need to wait for support. In the meantime, just wondering whether anyone else ran into this issue?

    • This topic was modified 6 months, 3 weeks ago by .
    • This topic was modified 6 months, 3 weeks ago by .
    #2013
    StandingWave
    Participant

    Ok a bit annoyed to be having to to type all of this again because it didn’t get posted the first time around!

    I realised that the sources are available for SoapySDR and SoapySDRPlay, however, I ren into difficulties when trying to compile both of them.

    When I run cmake on SoapySDR, I get:

    -- Could NOT find Python3InterpDbg (missing: PYTHON3_DBG_EXECUTABLE) 
    -- PYTHON3INTERP_FOUND: TRUE
    -- PYTHON3_EXECUTABLE: /usr/bin/python3
    -- PYTHON3_INSTALL_DIR: ${prefix}/lib/python3.9/dist-packages
    -- Found Python3Libs: -L/usr/lib/python3.9/config-3.9-aarch64-linux-gnu -L/usr/lib  -lcrypt -lpthread -ldl  -lutil -lm -lm  
    -- PYTHON3LIBS_FOUND: TRUE
    -- PYTHON3_INCLUDE_DIRS: /usr/include/python3.9;/usr/include/python3.9
    -- PYTHON3_LIBRARIES: -L/usr/lib/python3.9/config-3.9-aarch64-linux-gnu -L/usr/lib  -lcrypt -lpthread -ldl  -lutil -lm -lm

    Nevertheless, make still compiles the library and libSoapySdr.so.0.8.1 gets build and installed with make install.

    When I then proceed to compile the SoapySDRPlay library I get:

    • This reply was modified 6 months, 3 weeks ago by .
    • This reply was modified 6 months, 3 weeks ago by .
    #2016
    StandingWave
    Participant

    What is going on with this forum!! It seems to keep loosing bits of my post!

    Ok, to continue, this is what I get:

    -- Build type not specified: defaulting to release.
    -- libsdrplay not found.
    CMake Error at CMakeLists.txt:16 (message):
      SDRplay development files not found...
    
    -- Configuring incomplete, errors occurred!
    See also "/home/johnc/src/SoapySDRPlay/build/CMakeFiles/CMakeOutput.log".

    I have installed libpython3.dbg and libpython3.9.dbg libraries but this makes no difference. I am wondering whether I need to solve this first problem with the debug library in order to get the second library compiled?

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.