SDRplay RSP2/RSP2pro on Linux a Nightmare

SDRPlay Independent Community Forum Forums General SDRplay RSP2/RSP2pro on Linux a Nightmare

  • This topic has 1 reply, 2 voices, and was last updated by .
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #1830
    ilektranik
    Participant

    I once had the RSP2/RSP2pro installed and running on an Ubuntu 18 machine. It worked well.

    Last fall I reinstalled Ubuntu 18 on that machine. Everything works well except the RSP2pro and CubicSDR will not successfully install after months of off and on trying.

    Today I tried again. Using the instructions from https://github.com/cjcliffe/CubicSDR/wiki/Build-Linux#wiki-pages-box, which was edited 7 hours ago (04/23/2021), I still have no luck.

    I’m not new to Linux. I’ve got a BSIT, Linux+, S+, CISSP, etc. Ubuntu 18 LTS is my daily driver on 3 workstations. I use Debian, Ubuntu, Kali and godforsaken Win 10 LTSC in innumerable VM instances. I make a living running Kali. Just saying.

    I’m wondering if cjcliffe left a few ‘cd’ commands out in the procedure. For example between ‘Build and install SoapySDR’ and ‘Build and install liquid-dsp’ sections. Taking the prompt as a cue I reverted to ~/ before ‘Build and install liquid-dsp’.

    I’m also wondering if incomplete removal of previous install failures is to blame. I manually removed everything I could find.

    Any ideas? Anyone successfully do a recent Linux install?

    Here are a few of the issues:

    wxWidgets-3.1.5$ ./configure –with-opengl –disable-glcanvasegl –disable-shared –enable-monolithic –with-libjpeg –with-libtiff –with-libpng –with-zlib –disable-sdltest –enable-unicode –enable-display –enable-propgrid –disable-webkit –disable-webview –disable-webviewwebkit –prefix=echo ~/Develop/wxWidgets-staticlib CXXFLAGS=”-std=c++0x”

    configure: error: unrecognized options: –disable-webkit

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ./configure –with-opengl –disable-glcanvasegl –disable-shared –enable-monolithic –with-libjpeg –with-libtiff –with-libpng –with-zlib –disable-sdltest –enable-unicode –enable-display –enable-propgrid –disable-webkit –disable-webview –disable-webviewwebkit –prefix=echo ~/Develop/wxWidgets-staticlib CXXFLAGS=”-std=c++0x”

    configure: error: unrecognized options: –disable-webkit

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~/CubicSDR/build$ cmake ../ -DCMAKE_BUILD_TYPE=Release -DwxWidgets_CONFIG_EXECUTABLE=~/Develop/wxWidgets-staticlib/bin/wx-config

    — HAMLIB was not found.
    CMake Error at CMakeLists.txt:99 (message):
    hamlib development files not found…

    — Configuring incomplete, errors occurred!
    See also “/home/ilektranik/CubicSDR/build/CMakeFiles/CMakeOutput.log”.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    make

    make: *** No targets specified and no makefile found. Stop.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ./CubicSDR

    bash: ./CubicSDR: No such file or directory

    #1831
    fventuri
    Participant

    ilektranik,
    looks like the config flag ‘–disable-webkit’ is no longer supported in wxWidgets version 3.1.5.

    I ran ‘configure’ with this command and it finished without errors:

    ./configure --with-opengl --disable-glcanvasegl --disable-shared --enable-monolithic --with-libjpeg --with-libtiff --with-libpng --with-zlib --disable-sdltest --enable-unicode --enable-display --enable-propgrid --disable-webview --disable-webviewwebkit --prefix=/usr/local CXXFLAGS="-std=c++0x"

    Hope this helps,
    Franco

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.