SDRplay RSP2/RSP2pro on Linux a Nightmare

SDRPlay Independent Community Forum Forums General SDRplay RSP2/RSP2pro on Linux a Nightmare

  • This topic has 5 replies, 4 voices, and was last updated by .
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1830
    ilektranik
    Participant

    I once had the RSP2/RSP2pro installed and running on an Ubuntu 18 machine. It worked well.

    Last fall I reinstalled Ubuntu 18 on that machine. Everything works well except the RSP2pro and CubicSDR will not successfully install after months of off and on trying.

    Today I tried again. Using the instructions from https://github.com/cjcliffe/CubicSDR/wiki/Build-Linux#wiki-pages-box, which was edited 7 hours ago (04/23/2021), I still have no luck.

    I’m not new to Linux. I’ve got a BSIT, Linux+, S+, CISSP, etc. Ubuntu 18 LTS is my daily driver on 3 workstations. I use Debian, Ubuntu, Kali and godforsaken Win 10 LTSC in innumerable VM instances. I make a living running Kali. Just saying.

    I’m wondering if cjcliffe left a few ‘cd’ commands out in the procedure. For example between ‘Build and install SoapySDR’ and ‘Build and install liquid-dsp’ sections. Taking the prompt as a cue I reverted to ~/ before ‘Build and install liquid-dsp’.

    I’m also wondering if incomplete removal of previous install failures is to blame. I manually removed everything I could find.

    Any ideas? Anyone successfully do a recent Linux install?

    Here are a few of the issues:

    wxWidgets-3.1.5$ ./configure –with-opengl –disable-glcanvasegl –disable-shared –enable-monolithic –with-libjpeg –with-libtiff –with-libpng –with-zlib –disable-sdltest –enable-unicode –enable-display –enable-propgrid –disable-webkit –disable-webview –disable-webviewwebkit –prefix=echo ~/Develop/wxWidgets-staticlib CXXFLAGS=”-std=c++0x”

    configure: error: unrecognized options: –disable-webkit

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ./configure –with-opengl –disable-glcanvasegl –disable-shared –enable-monolithic –with-libjpeg –with-libtiff –with-libpng –with-zlib –disable-sdltest –enable-unicode –enable-display –enable-propgrid –disable-webkit –disable-webview –disable-webviewwebkit –prefix=echo ~/Develop/wxWidgets-staticlib CXXFLAGS=”-std=c++0x”

    configure: error: unrecognized options: –disable-webkit

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~/CubicSDR/build$ cmake ../ -DCMAKE_BUILD_TYPE=Release -DwxWidgets_CONFIG_EXECUTABLE=~/Develop/wxWidgets-staticlib/bin/wx-config

    — HAMLIB was not found.
    CMake Error at CMakeLists.txt:99 (message):
    hamlib development files not found…

    — Configuring incomplete, errors occurred!
    See also “/home/ilektranik/CubicSDR/build/CMakeFiles/CMakeOutput.log”.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    make

    make: *** No targets specified and no makefile found. Stop.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ./CubicSDR

    bash: ./CubicSDR: No such file or directory

    #1831
    fventuri
    Participant

    ilektranik,
    looks like the config flag ‘–disable-webkit’ is no longer supported in wxWidgets version 3.1.5.

    I ran ‘configure’ with this command and it finished without errors:

    ./configure --with-opengl --disable-glcanvasegl --disable-shared --enable-monolithic --with-libjpeg --with-libtiff --with-libpng --with-zlib --disable-sdltest --enable-unicode --enable-display --enable-propgrid --disable-webview --disable-webviewwebkit --prefix=/usr/local CXXFLAGS="-std=c++0x"

    Hope this helps,
    Franco

    #1856
    Anonymous

    This is what I did to get CubicSDR running on a fresh install of Ubuntu 18.04.3

    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install build-essential
    sudo apt-get install libsoapysdr0.6
    sudo apt-get install libsoapysdr-dev
    sudo apt-get install libopenal-dev
    sudo apt-get install libliquid-dev
    sudo apt-get install freeglut3
    sudo apt-get install freeglut3-dev
    sudo apt-get install libalut0
    sudo apt-get install libalut-dev
    sudo apt-get install cubicsdr

    some of the steps are not needed, but they do not hurt.

    #1865
    ilektranik
    Participant

    That works well to install CubicSDR and is short and sweet.

    The problem being that although the RSP2PRO is present, as shown by lsusb, CubicSDR cannot find it.

    SoapySDRUtil –find shows No Devices found!

    After:
    export LD_LIBRARY_PATH=/usr/local/lib

    SoapySDRUtil –find shows No Devices found!

    Back where I was after many hours spent on the instructions from https://github.com/cjcliffe/CubicSDR/wiki/Build-Linux#wiki-pages-box last April.

    #1869
    GeorgeV73GT
    Participant

    I am running Centos 7 and trying to install the SDRPLAY software.

    Get the “HAMLIB not found” error amoung a many others.

    Two of the additional troubles i am having is can’t get apt or apt-get to work nor cmake-essentials (though i installed the CENTOS equivalent).

    Any one else out there successfully get SDRPLAY running under Cento or RHEL?

    Thanks in advance.

    George

    #1870
    ilektranik
    Participant

    George,

    The extremely competent Kevin Loughin, KB9RLW, has a new procedure using the latest Soapy. Had my RSP2Pro running with CubicSDR in a jiffy after a year of being unable to resolve all the drivers, etc. due to Ubuntu updates (I believe).

    See:
    https://kb9rlw.blogspot.com/2021/06/a-simple-script-to-get-sdrplay-hardware.html

    A simple script to get SDRPlay hardware running on Linux.

    He speaketh the truth.

    73,

    Tommy
    KW4PF

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.