RSPduo clock phase drift?

SDRPlay Independent Community Forum Forums SDRPlay Devices RSPduo clock phase drift?

  • This topic has 2 replies, 2 voices, and was last updated by .
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #971
    brianbgarber
    Participant

    Hello all,

    I noticed that when I decode WEFAX images with the RSPduo, I end up getting lots of fldigi phasing errors. (See attached image) From the image, you can see that I had plenty of SNR, but something else was going on with the phase (perhaps?).

    However, I do not get this issue when decoding WEFAX images with either an RTL-SDR or an IC-7300. My initial thought was that the software was taxing my computer, but I’ve tried both SDRuno and HDSDR with the exact same results.

    Thanks,
    Brian

    #972
    brianbgarber
    Participant

    Sorry, here is the image…

    Attachments:
    #1063
    scottlirwin
    Participant

    I have experienced the same issue. I reached out to SDRPlay and received the following:

    This is not something that we have any personal experiences of when using a Raspberry Pi, but of course may people do receive WEFAXs using RSPs on PC systems. AlI can do is to really speculate what the problem might be, but on a PC, if your system load gets too high, then you can hit a CPU load of 100% on one core of the processor and this leads to buffer under-runs on the data from the RSP and momentary data loss. When the data is restored, sync has been lost in the WEFAX. The only way to avoid this is the ensure that the CPU load is as low as possible and on a Raspberry Pi, that is not so easy. I suggest that you reduce the sample rate to as low as possible when you are receiving data to see if that helps. Beyond that, I am afraid I do not know what to suggest.

    Best regards

    Tech_SUpport

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.