RSP1 Linux no way?

Tagged: ,

  • This topic has 5 replies, 3 voices, and was last updated by .
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1934
    eyilmaz
    Participant

    Hello,

    Well there is no charming GUI like in Windows with Linux. But..

    I’m not ably to run my RSP1 on Linux Mint. I tried almost every solution found on Internet. The final stage is, API is working, all dependencies are ok. For example SDR++ starts. SDRPlay selection on menu work. But no device. The device is not found. Almost giving up.

    Anybody have it running?

    #1935
    rocky28965
    Participant

    Apparently there is, I haven’t tried it myself but

    Step-by-step install guide for the RSP2 under Ubuntu 16.04

    #1940
    StandingWave
    Participant

    Probably needs a little more detail, but I presume you installed the API, SoapySDR and SoapySDRPlay and ran the following commands:

    SoapySDRUtil –info

    This should report back the API version and library versions confirm the location of libsdrPlaySupport.so.

    SoapySDRUtil –probe=”driver=sdrplay”

    This should report back the RSP hardware version details.

    I haven’t tried SDR++ yet and didn’t like the fact that the .deb installer wanted to remove the current version of one of my libraries and replace it with an old version. Since I wasn’t sure what effect this might have I cancelled the install. However I did try compiling Cubic SDR instead and this did find my RSP2 and worked fine with it. The reason I compiled from source was because the appimage version does not find the SoapySDRPlay library. I suspect that it requires the older version of the API. The sources compiled fine with the current versions of the API and SoapySDR libraries.

    Quite some time ago I started a thread on running SDRuno on Linux under WINE. It required the ExtIO version of the program to be used and this connected to the rsp_tcp server on Linux. That was under version 1.2 of SDRuno. SDRplay then dropped the ExtIO variant in 1.3x. However I see that it is available again in version 1.41. If you have WINE installed, this might be one possible approach to try. The thread is on the old forum here:

    https://sdrplay.com/community/viewtopic.php?f=11&t=4187

    More recently I also tried installing SDRuno in a Windows 10 VM and that seems to work although the signal did abruptly stop occasionally. I might try using the TCP server approach rather than passing the USB port though to the VM to see whether that improves things.

    #1941
    StandingWave
    Participant

    I compiled SDR++ today and managed to get it working with my RSP2. The compilation process is a bit tricky and I had to edit CMakeLists.txt in order to compile only for the RSP and also the RTLSDR dongles that I have. I don’t have an Airspy or HackRF so no reason to install these dependencies or compile these modules so I turned them off. The following two lines are relevant to the RSP:

    option(OPT_BUILD_SDRPLAY_SOURCE “Build SDRplay Source Module (Dependencies: libsdrplay)” ON)
    option(OPT_BUILD_SOAPY_SOURCE “Build SoapySDR Source Module (Dependencies: soapysdr)” ON)

    Both must be turned ON. By default, OPT_BUILD_SDRPLAY_SOURCE is turned off and will not be built. Anything not required can be tuned OFF.

    Once the application was built and installed, I was able to pick SDRPLAY from the list of sources and could receive signals. Unfortunately the audio sounded terrible. There was a horrible warbling effect which I couldn’t get rid off no matter how much I tweaked the settings so something still a bit wrong here.

    If you are installing from the .deb file, it is possible that since SDRplay is turned off by default in the sources, it may be turned off in the supplied package. I am only speculating and you would have to contact the project author.

    • This reply was modified 1 day, 22 hours ago by .
    • This reply was modified 1 day, 22 hours ago by .
    #1944
    StandingWave
    Participant

    Just an update. This fixed my audio problem:

    https://github.com/AlexandreRouma/SDRPlusPlus/discussions/112

    I now have SDR++ working properly with my RSP2.

    • This reply was modified 1 day, 14 hours ago by .
    #1947
    StandingWave
    Participant

    I also then tried connecting SDRuno in a Windows 10 virtual machine to the rsp_tcp server with ExtIO dll version 1.2 on the Linux host and that worked fine but there are missing features such as the scanner. However, it did seem much more stable this way than it was with passing the USB port through to the VM.

    I did have difficulty with configuring the Antenna on the RSP2 as the OPT dialog would not in initially show either Antenna B or the High-Z one. Sometimes after starting and stopping the receiver a couple of times, it would show the other antennas, but when I tried to select Hi-Z I got this rather strange message:

    “Input can only be selected below 0 MHz”

    Not sure what to make of that. The options would then disppear from the drop down again. I would appreciate it if someone from SDRplay could explain what is going on here?

    At least it works in principle so there are possibilities for running RSP SDR radios under Linux but they do require a bit of work to set up.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.