Raspberry Pi Workaround for analog audio not working

SDRPlay Independent Community Forum Forums SDR Software (RSP Compatible) Raspberry Pi Workaround for analog audio not working

  • This topic has 0 replies, 1 voice, and was last updated by .
Viewing 1 post (of 1 total)
  • Author
    Posts
  • #659
    Kiteboarder
    Participant

    Longtime RSP user, first time poster.

    I can’t find any note on a solution to the official SDRPlay Raspberry Pi Image User Guide note in the V0.6 documentation regarding the Analog out audio not functioning when using a HDMI display.

    As suggested in the notes, using an external USB soundcard is a plug in workaround which i used for a while, I’ve had a fiddle and got a workaround (not a fix) to make my analog audio port working.

    My setup is a RaspPi 4 with a RSP2. I tried this with the “out of the box” image and also with the latest Buster updates applied.

    Open the RaspPi command line app

    sudo raspi-config
    Select option 7 Advanced Options
    Select option A4 Audio
    Select option 1 Force 3.5mm (‘headphone’) jack
    Then reboot

    That seems to enable the analogue output and seems immune to “not working after a reboot”.

    There is a bash script that runs on boot /home/pi/scripts/initDisplay.sh that appears to want to try call a missing /home/mon.txt file, re-write the config.txt file with a defaulted version every time, then reboot. This seems to generate some permission errors, visible when running a shell login… this may have something to do with the audio issue but I haven’t fiddled much yet.

    Dave

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.