New SDRPLAY with Suse Linux

SDRPlay Independent Community Forum Forums SDRPlay Devices New SDRPLAY with Suse Linux

  • This topic has 0 replies, 1 voice, and was last updated by .
Viewing 1 post (of 1 total)
  • Author
    Posts
  • #1612
    richardrosa
    Participant

    Greetings All,

    After several years of playing with a cheap RTLDSR, I decided to upgrade to
    something that was a bit more polished. I settled on an DSRPLAY RSPdx. I’m
    beginning to wonder if this was a mistake…

    I do NOT own any Windows machines. I run Suse Linux. The Suse repositories provide
    a number of very nice SDR applications (GQRX/DUMP1090/etc) that worked fine with the
    RTLSDR. None of these pre-built applications appear to function with the SDRPLAY.

    The ONLY way that I have been able to utilize this SDR is by downloading and
    running the 6 scripts available on the SDRPLAY site. These scripts took about
    an hour to execute (long compilations and 4 reboots). When they completed, I
    was able to run CubicSDR only. Unfortunately, I find this program a bit cumbersome, and
    it seems to have a few annoying quirks.

    I have downloaded and compiled the latest source for GQRX (v2.11.5).
    It does not recognize the SDRPLAY.
    I have tried selecting ‘other’ as the device, with the string:
    “soapy=0,driver=sdrplay”, as suggested, but the program does not communicate
    with the device.

    I’ve also tried downloading and compiling DUMP1090 binaries, but they throw some
    cryptic C errors (I have ZERO ‘C’ coding skills).

    Can anyone suggest how I can get at LEAST GQRX & DUMP1090 working with this
    device? Or should I return this unit from whence it came and exchange it
    for a device with better Linux support?

    Thanx.

    Richard Rosa

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.