I cannot install SDRplay on my LinuxMint 19.03

SDRPlay Independent Community Forum Forums SDR Software (RSP Compatible) I cannot install SDRplay on my LinuxMint 19.03

Tagged: ,

  • This topic has 3 replies, 4 voices, and was last updated by .
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1959
    IlyaT
    Participant

    The first thing I did was to add the available drivers to the blacklist.
    no oroginal drivers enabled
    Then I downloaded the installation scripts from the website. And it seems that the first script, which installs the API completed without errors
    lsusb output
    SoapySDRUtil –info
    Then I run the second script *2buildSoapy.sh and it terminates with an error
    *2buildSoapy.sh
    When I run SoapySDRUtil –probe=”driver=sdrplay” I get this message
    probe error

    #2011
    StandingWave
    Participant

    What does the CMakeOutput.log say?
    Can you post the output of ./configure please?

    It does look like there may be a missing dependecy.

    #2032
    DrAnony
    Participant

    I’m hoping someone can help me as well. I’m trying to use the build scripts from the SDRPlay.com/downloads area.

    I ran both:

    1installAPI.sh
    2buildSoapy.sh

    and don’t believe there were any errors. I rebooted and get the following from lsusb:

    Bus 002 Device 005: ID 046d:c534 Logitech, Inc. Unifying Receiver
    Bus 002 Device 004: ID 1df7:3000  
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 138a:003c Validity Sensors, Inc. VFS471 Fingerprint Reader
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    When running Soapyutil, I get this error:

    SoapySDRUtil -probe="driver=sdrplay"
    ######################################################
    ##     Soapy SDR -- the SDR abstraction library     ##
    ######################################################
    
    Probe device driver=sdrplay
    Error probing device: no available RSP devices found

    I’m on linux mint 20.2.

    Any help greatly appreciated!

    #2048
    g8kbv
    Participant

    Hi.

    I’m also trying to do this, on Mint 19.3 64 bit, all up-to-date. The biggest issue I have, is sorting the wheat from the chaff of all the different “instructions” out there that all conflict with each other. There seems to be no one definitive “this is the correct way” to install and get this running document. Or, if there is, I’ve yet to stumble across it.

    I have GQRX installed for some time, and have used that extensively with various RTLSDR devices, but now I wish to get a “donated” RSP1 to work.

    In the short term, just getting it to record short wideband I/Q recordings covering the lower HF bands would be good. (For VDSL leakage detection.)

    I’ve checked it on a Windows box at work, with SDR console, and it works very well, but I have absolutely drawn a blank on getting it working on Linux. Even the CubicSDR AppImage fails to see it.

    Is there a single proven reference one can work through to get this working? (Is there any overall documentation explaining how all the various pieces of code work together?)

    Also, is there an easy way to find and uninstall/remove what the API/Driver script dumped somewhere undocumented on my system?

    I’ve built other applications from source (WSJTx, Fldigi and others OK) But this software has my head spinning.

    Any help welcome please.

    73. Dave G8KBV

    PS: And just “Why” is SoapySDR actually called that! (Ive got visions of soap bubbles coming out of somewhere!)

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.