Absolute Frustration

  • This topic has 8 replies, 3 voices, and was last updated by .
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #1157

      I want to share my experience as a new owner.

      I own a number of SDR devices. Having done lots of research I bought a RSP1A a few days ago.
      Since then having spent many hours I have not got it working on any machine I have.

      Here is the list:
      I have tried to install on Win 10 – failed driver blocked. Viros check switched off – no clue how to fix?

      Win 7 machine – did manage to get software installed but software freezes after a few seconds with buffer overflow error – result unusable.

      Two Win 7 virtual machines – driver signature 52 error. Tried to allow by editing registry – no go wont run.

      Two Linux laptops ubuntu 20.04– followed the near impossible copmplex instructions watched the video. Instructions are incomplete. Failed to recognize or install the RSP1A.

      So far I have a RSP1A that looks like it is destined for the draw of useless gadgets I should not have bought.

      To note, all my other SDRs insatlled with no problem on all of these paltforms.

      This is by far the most difficult device to install device I have ever had experience of – truly regret buying and a waste of hard earned cash.


        My frustartion goes on.

        The unit is new out of the box. I have just found the plastic is cracked around the SMA connector.


          Don’t muck about Alan, raise a ticket via the main site. The SDRPlay guys are very good and will put you right.


            Hi Andy

            I bought the RSp1A because I wanted to support a UK company. I am an engineer who has founded start-ups so wanted to help an inovative company by purchasing from them. Reviews all looked good with an apparent excellent value for money specification.

            Sadly the RSP1A did not meet upto expectations.

            I am experienced with Linux and Windows but was utterly defeated in getting to work reliably. Tried on several Pcs and operating system.

            I did manage to install on a windows 7 pc but the Sdrplay software continuously locked up and froze the pc reporting buffer errors. Final straw was a crack in the case near the SMA that looks likely due to poor quality control during manufacture.

            In my opinion the Rsp1a has good potential but let down by poor quality plastic case and near impossible to install drivers. I have other sdrs that work out of the box on windows7/10 and linux. Installing on Linux with the RSP1A is extremely difficult with complex instructions and need to compile software and after all of that it still did not work.

            So after many hours of trying I gave up and have decided it is too difficulty to get working. I don’t want to fight with something that I just want to use.

            I am going return the RSP1A and buy a competitors brand.


              That’s a shame Alan. I can’t understand why you are having such a tussle with the installation. There is just one thing to install (SDRUno) and it brings all the drivers etc with it and installs them. Quite why it won’t work in your case is baffling.
              I’ve had three models of RSP, an original ‘1’, then a ‘2’ and now a Duo and they all installed in one shot without any snags on my W8 laptop, then on my new W10 laptop. Still, that’s computers for you.
              Good luck.


                I am sorry you have had these issues. I own an RSP1a and a RSPdx, both run out of the box, under Windows 10. I also run my RSP1a on a Raspberry Pi 4 with a long term server. Running for days and tests now.


                  I wonder too. Taking on this kit needs interest in the first place. I suspect the original posters problems.

                  • This reply was modified 3 years, 10 months ago by .

                    Really Alan. I run 24 hours a day an RSP1a on a Raspberry Pi 4 without issues. Contact me for help. I own an RSPdx also.



                      I bought this product in good faith wanting to use it for fun and education. I think there is some inference in the response to my posting that I have some other motative for posting. The RSP1A is sold as a finished product that should work with reasonable effort. I am not a novice and own other Sdrs. With the RSP1A, I spent hours without success trying to get the drivers install. I could be unlucky or accept I don’t have the skill. What I have reported is just my personal experience. My conclusion is yes it potentially has good features but it is going to be problematic to many to get working.

                      Secondly, the plastic box came with a serious crack in it around the SMA.

                      I have since bought an Airspy and it worked out of the box on all of the platforms both PC and operating systems where the RSP1A would not.

                      I can state I have no bias or connection to any product, and just wanted to make others aware of my experience and my disappointment.

                    Viewing 9 posts - 1 through 9 (of 9 total)
                    • You must be logged in to reply to this topic.