Reply To: RSP1 Linux no way?

#1941
StandingWave
Participant

I compiled SDR++ today and managed to get it working with my RSP2. The compilation process is a bit tricky and I had to edit CMakeLists.txt in order to compile only for the RSP and also the RTLSDR dongles that I have. I don’t have an Airspy or HackRF so no reason to install these dependencies or compile these modules so I turned them off. The following two lines are relevant to the RSP:

option(OPT_BUILD_SDRPLAY_SOURCE “Build SDRplay Source Module (Dependencies: libsdrplay)” ON)
option(OPT_BUILD_SOAPY_SOURCE “Build SoapySDR Source Module (Dependencies: soapysdr)” ON)

Both must be turned ON. By default, OPT_BUILD_SDRPLAY_SOURCE is turned off and will not be built. Anything not required can be tuned OFF.

Once the application was built and installed, I was able to pick SDRPLAY from the list of sources and could receive signals. Unfortunately the audio sounded terrible. There was a horrible warbling effect which I couldn’t get rid off no matter how much I tweaked the settings so something still a bit wrong here.

If you are installing from the .deb file, it is possible that since SDRplay is turned off by default in the sources, it may be turned off in the supplied package. I am only speculating and you would have to contact the project author.

  • This reply was modified 6 months, 4 weeks ago by .
  • This reply was modified 6 months, 4 weeks ago by .