Reply To: RSP1 Linux no way?


    Probably needs a little more detail, but I presume you installed the API, SoapySDR and SoapySDRPlay and ran the following commands:

    SoapySDRUtil –info

    This should report back the API version and library versions confirm the location of

    SoapySDRUtil –probe=”driver=sdrplay”

    This should report back the RSP hardware version details.

    I haven’t tried SDR++ yet and didn’t like the fact that the .deb installer wanted to remove the current version of one of my libraries and replace it with an old version. Since I wasn’t sure what effect this might have I cancelled the install. However I did try compiling Cubic SDR instead and this did find my RSP2 and worked fine with it. The reason I compiled from source was because the appimage version does not find the SoapySDRPlay library. I suspect that it requires the older version of the API. The sources compiled fine with the current versions of the API and SoapySDR libraries.

    Quite some time ago I started a thread on running SDRuno on Linux under WINE. It required the ExtIO version of the program to be used and this connected to the rsp_tcp server on Linux. That was under version 1.2 of SDRuno. SDRplay then dropped the ExtIO variant in 1.3x. However I see that it is available again in version 1.41. If you have WINE installed, this might be one possible approach to try. The thread is on the old forum here:

    More recently I also tried installing SDRuno in a Windows 10 VM and that seems to work although the signal did abruptly stop occasionally. I might try using the TCP server approach rather than passing the USB port though to the VM to see whether that improves things.