Reply To: New Raspberry Pi image for RSPdx

SDRPlay Independent Community Forum Forums General New Raspberry Pi image for RSPdx Reply To: New Raspberry Pi image for RSPdx



    RSPdx has arrived. I have CubicSDR running on my Pi4 and can manipulate the RSPdx ok. But… When I run ‘lsusb’ all I see is:

    Bus 001 Device 004: ID 1df7:3030 – And thats fine, as 3030 is the RSPdx

    This does not appear to be sufficient for ANY version of dump1090 to reckognise.

    When I downloaded the SDRPlay DUMP1090 from gitbih, all ran OK until I ran the ‘make’ command and it balked:

    pi@rspdx:~$ cd dump1090/
    pi@rspdx:~/dump1090$ sudo make
    gcc -DMODES_DUMP1090_VERSION=\””dump1090_mutability_sdrplay”\” -O3 -g -Wall -Werror -W -static -DSDRPLAY -I./ pkg-config --cflags librtlsdr -c dump1090.c -o dump1090.o
    In file included from dump1090.c:50:
    dump1090.h:232:10: fatal error: mirsdrapi-rsp.h: No such file or directory
    #include “mirsdrapi-rsp.h”
    compilation terminated.
    make: *** [Makefile:48: dump1090.o] Error 1

    Any help would be greatly appreciated.